Excel-Zeit

on

Auf Grund unvorhergesehener Vorfälle gestern, musste ich heute doch mal meine Backup-Gleitzeit-Berechnung in Excel auf den neuesten Stand bringen.

Ausgangslage laut Gesetzgeber:

Nach 6 Stunden Arbeitszeit, 30 Minuten Pause: Sprich, bei Überschreiten der 6:30 wird einfach die halbe Stunde wieder abgezogen.
Nach über 9 Stunden Arbeitszeit nochmal ne viertel Stunde Pause. Oder besser: Die Uhr wird für eine viertel Stunde angehalten.

Bisher ist letzteres so selten aufgetreten, dass ich diesen Umstand vernachlässigt habe und dann einfach händisch in meine schöne automatisierte Excel-Tabelle geschrieben hab. Das war mir heute Morgen dann langsam echt zu doof. Wofür bin ich schließlich Anwendungsentwickler…

Also Pseudo-Code hingeschmiert um die Gedanken in die Reihe zu bekommen

Anfangszeit = AZ
Endzeit = EZ

Wenn (EZ – AZ)>6:30 dann
Wenn(EZ-AZ)>9:30 && (EZ-AZ)<=9:45 dann
Zeit = 9:00
Sonst
Wenn (EZ-AZ) > 9:45 dann
Zeit = EZ-AZ-0:45
Sonst
Zeit = EZ-AZ-0:30
Sonst
Zeit = EZ-AZ

Sieht logisch aus (Ja, ich weiß, die Dönerstage sind hier nicht berücksichtigt, aber leider stellt Excel die Abfrage

if(doenermember.contains(„$Nicht-näher-benannter-WAS-Admin“){
//Berechnung der Mittagspause unter zuhilfenahme von Pi
//und der kosmischen Strahlung
}

noch nicht zur Verfügung) und wäre in jeder sinnvollen Programmiersprache auch sehr sinnvoll zu programmieren.

Nicht in Excel… Zumindest sieht es da doch reichlich hässlich aus als Formel.
Über den Wahn, die Befehle eindeutschen zu müssen will ich mich mal gar nicht auslassen. Wahrscheinlich ist das der gleiche Grund, der auch Cobol verursacht hat: „Ziel war es, eine Programmiersprache zu entwickeln, die auch Kaufleute lesen und schreiben können“ – Zitat Cobol-Dozent.

Am Ende hat man dann also folgenden Wurm dastehen (In Excel natürlich schön in einer Zeile, aber ich vermute, dass das meinem Blog zu breit wird)

=WENN(C144-B144>$B$2;
WENN(UND(C144-B144>$D$1;C144-B144<=$E$1);
$F$1;
WENN(C144-B144>$E$1;
C144-B144-$E$2;
C144-B144-$D$2));C144-B144)

Kopiert das mal in die Formelzeile von Excel und freut euch über die vielen bunten Farben. Außerdem wärs mal nett zu wissen, ob man bei einer 1024er Auflösung schon einen Scrollbalken bekommt 🙂
Besonderes Highlight der Formel: Die Und-Verknüpfung! =UND(Wert1;Wert2;Wert3….)
Hallo?! Was wärs denn mit & oder &&? Dass in einer Formel das + nicht als Verknüpfung taugt ist mir auch klar. Aber „UND“?!